1. Offices & Services
  2. Technology Services Center
  3. Technology Requirements

Staying current with productivity technology is an important part of your education. We therefore want to make certain that you have all the necessary resources available to successfully complete your course work. Please review the information presented below to make certain that you possess the necessary tools and requirements.

Note: While tablets, smartphones and other mobile devices may allow access, they are not guaranteed to work in all areas. Please ensure you have a Windows or Mac based computer available to complete coursework in the event your selected mobile device does not meet the needs of the course.

ExamSoft Requirements:

Some courses may require additional computer requirements set by ExamSoft. You can check additional requirements based on your OS here. Please note, minimum requirements of ExamSoft may not meet the University minimum requirements.

Supported Hardware (Minimum requirements)

  • Processor: 2GHz processor
  • Memory: 4GB
  • Hard Drive: 160GB
  • DVD-ROM: Required
  • Sound Card, Microphone, and Speakers: Required
  • Adapter: Wireless Adapter
  • Internet Connection: Broadband
  • Webcam: Required

Supported Operating Systems

  • Windows 7
  • Windows 8.x
  • Windows 10 (Please note Windows RT and Windows RT 8.1 are not supported.)
  • MAC OS X 10.8 and higher is supported for most course materials, but there may be applications that require a supported Windows Operating System (e.g. Microsoft Office 365).

Productivity Tools

  • Microsoft Office 2013 or 2016 (Windows)
  • Microsoft Office 2013 (MAC).

Supported Internet Browsers
The following are supported browsers:

Note: We recommend installing multiple browsers for use with our technologies, some web based applications may not fully function due incompatibility issues, try using a different browser before calling support.

Windows OS Users

  • Microsoft Internet Explorer 11 and higher (Recommended)
  • Google Chrome 49 and higher
  • Mozilla Firefox 45 and higher

Mac OS Users

  • Google Chrome 49 and higher (Recommended)
  • Mozilla Firefox 45 and higher

Additional Settings
Please refer to your browser's Help features to check these settings.

  • Pop-Up Blocker should be disabled
  • Cookies should be enabled
  • Local Administrator

Third-Party Applications

  • Adobe Flash Player
  • Adobe Acrobat Reader (Version 9, 11, or DC)
  • Java v7 or higher
  • Antivirus application (updated regularly)

Occasionally a course may require additional plug-ins not listed here, but plan to have the plug-ins listed above installed in advance.